酷源码-帝国cms模板及插件下载交流论坛

×

用户登录

  1. 用户名:
  2. 密    码:
  3. 注册

百度快速排名1-7天上首页
帝国cms插件定制开发
★香港+美国BGP服务器★
香港+美国BGP服务器
帝国cms小程序定制开发
帝国cms建站定制开发
文字广告位出租10点/天
文字广告位出租10点/天
文字广告位出租10点/天
文字广告位出租10点/天
文字广告位出租10点/天
文字广告位出租10点/天
文字广告位出租10点/天
文字广告位出租10点/天
文字广告位出租0点/天

查看: 回复:0

解决帝国cms上传文件大小的限制php.ini设置方法

 

2928

主题

2928

帖子

1

积分

管理员

版主

积分
1
登陆

Warning: Illegal string offset 'loginnum' in /www/wwwroot/kyuanma.com/e/data/tmp/dt_temptext13.php on line 257
私信
注册时间

Warning: Illegal string offset 'registertime' in /www/wwwroot/kyuanma.com/e/data/tmp/dt_temptext13.php on line 261

Warning: date() expects parameter 2 to be long, string given in /www/wwwroot/kyuanma.com/e/data/tmp/dt_temptext13.php on line 261
最后登陆时间

Warning: Illegal string offset 'lasttime' in /www/wwwroot/kyuanma.com/e/data/tmp/dt_temptext13.php on line 263

Warning: date() expects parameter 2 to be long, string given in /www/wwwroot/kyuanma.com/e/data/tmp/dt_temptext13.php on line 263
楼主
发表于 2020-10-14 09:22:53
跳转

1. 一般的文件上传,除非文件很小.就像一个5M的文件,很可能要超过一分钟才能上传完.
但在php中,默认的该页最久执行时间为 30 秒.就是说超过30秒,该脚本就停止执行.
这就导致出现 无法打开网页的情况.这时我们可以修改 max_execution_time
在php.ini里查找

max_execution_time

默认是30秒.改为

max_execution_time = 0

0表示没有限制2. 修改 post_max_size 设定 POST 数据所允许的最大大小。此设定也影响到文件上传。
php默认的post_max_size 为2M.如果 POST 数据尺寸大于 post_max_size $_POST 和 $_FILES superglobals 便会为空.
查找 post_max_size .改为

post_max_size = 150M

3. 很多人都会改了第二步.但上传文件时最大仍然为 8M.
为什么呢.我们还要改一个参数upload_max_filesize 表示所上传的文件的最大大小。
查找upload_max_filesize,默认为8M改为

upload_max_filesize = 100M

另外要说明的是,post_max_size 大于 upload_max_filesize 为佳.

验证码 换一个

扫一扫,反馈当前页面

咨询反馈
扫码关注

阿里云代理商公众号

返回顶部